No heat at idle with new heater core

  • knowitall2840
  • Topic Author
  • Offline
  • 1st Gear
  • 1st Gear
More
5 days 18 hours ago #203879 by knowitall2840
No heat at idle with new heater core was created by knowitall2840
my 2002 nissan quest heat hasn't been working properly for a while it only get hot when driving. at idle it gets back cold.. after i took it to the mechanic for a misfire problem. i told them about the no heat problem. so they flushed the heater core, changed the thermostat and water pump. after all that it was the same thing so they told be the heater core is clogged and has to be changed but after hearing the quote i decided to take the job on myself. i changed out the heater core and the problem is still there. could it be another bad thermostat ?. please help

Please Log in or Create an account to join the conversation.

Advertisement
  • nightflyr
  • nightflyr's Avatar
  • Away
  • 6th Gear
  • 6th Gear
  • 2002 Nissan Xterra 3.3L 4X4
More
5 days 14 hours ago #203883 by nightflyr
Replied by nightflyr on topic No heat at idle with new heater core
Assuming you have a 3.3L.
What your describing sounds like air entrapment with in the cooling system.
Now if the system has been properly bleed and this is still occurring you may have a different issue.
Are you seeing any coolant loss over time?
Have you tested for a possible head gasket problem ( combustion gas test ) ?
Have you checked the radiator cap ?

Please Log in or Create an account to join the conversation.

  • knowitall2840
  • Topic Author
  • Offline
  • 1st Gear
  • 1st Gear
More
5 days 12 hours ago #203884 by knowitall2840
Replied by knowitall2840 on topic No heat at idle with new heater core
It probably does have air trapped how can I get that out?

Yes I do notice some Coolant loss over time.

I have not done a combustion gas test.

I haven't checked the radiator cap but I've never seen any leaks from it if that's what you mean

Please Log in or Create an account to join the conversation.

  • nightflyr
  • nightflyr's Avatar
  • Away
  • 6th Gear
  • 6th Gear
  • 2002 Nissan Xterra 3.3L 4X4
More
5 days 7 hours ago #203885 by nightflyr
Replied by nightflyr on topic No heat at idle with new heater core
It probably does have air trapped how can I get that out?
In general:


Yes I do notice some Coolant loss over time.
Is there a visible signs (puddles) or it just mysteriously disappears?

I have not done a combustion gas test.
Well that will depend on the answer above

I haven't checked the radiator cap but I've never seen any leaks from it if that's what you mean
I meant is the seal in good shape and does the relief spring function.

Please Log in or Create an account to join the conversation.

Time to create page: 0.242 seconds