Radiator fans won't come on when they're supposed to

  • previaheavier
  • Topic Author
  • Offline
  • 1st Gear
  • 1st Gear
More
2 days 13 hours ago #203897 by previaheavier
My Toyota Previa 2000 ACR30 (2AZFE) won't start the coolant fans at 90 C (194 F) when it should. The fans work fine when theyre connected to power. The previous owner had taken the car to the mechanic for this problem, and they put a paperclip in the connector of the coolant fan temp. switch so the fans can stay on the entire time. Surely there has to be a way to not have to keep the fans on all the time, so I've tried the following so far:

-Replaced Coolant Fan Temperature Switch (was bad before)
-Tested ECT sensor and connector, they both test fine
-Replaced Thermostat (it was bad before)
-Fan fuses are ok
-All 3 Fan Relays test ok when theyre disconnected and power supplied to them, they are relays 11, 14, 15 in this diagram:
japan-parts.eu/toyota/eu/2000/previa-tar...tch-relay-computer/2
however the sockets for relay 14 and 15 dont power the fans with ignition ON when bridging the 87 and 30 terminals with a paperclip as seen at 5:32 in this video:


Thoughts:
Im questioning whether relays 14, 15 are supposed to be a closed circuit and power the fans when you paperclip them like the video, or is the circuit always open until the coolant temp. switch passes 90C?
Also, could it just be that there is damage in the wiring and relays 14+15 aren't getting any power? Unfortunately I have not been able to find any wiring diagrams so far.

I am at my wits end with this and any insight would be greatly appreciated. Thank you for your time in reading this.

Please Log in or Create an account to join the conversation.

Advertisement
More
2 days 6 hours ago - 1 day 5 hours ago #203900 by college man
Nice diagnostic work so far. With you unplugging the coolant fan switch and the fan coming on tells me that the fan switch
is either having a problem or coolant flow to the sensor. Two options. With a scanner read coolant temp and with an ohm
meter unplug the coolant fan switch connector and check for continuity at the switch when at or above the temp.( The switch is
a break on temp rise) You should have no continuity. Pull the relay disable the fan. #2 Remove the fan switch and put it in a pot with
a thermometer and take the temp to and above the set point check continuity. On this one I would use two jumpers to the meters
leads to keep you safe from burns. Note the water should only go high as the threads. You could also try and clean the connector with
some brake clean just to rid any dirt.

Believe it or not Iam trying to help you.

Proud to be Eric The Car Guy Certified.

Over 10,000 posts strong.

Mobil1 New Jersey highway tested everyday.
Last edit: 1 day 5 hours ago by college man.

Please Log in or Create an account to join the conversation.

Time to create page: 0.280 seconds